Performance test -- connection refused


#1

Hey there. I am doing some performance tests with different frameworks.

I tested lotus in development mode and it was way to slow. Then I started it in production mode but it was blocking the concurrent requests, probably by a security middleware. I got “connection refused”.

Is there a config for preventing this connection refused feature?

TIA


#2

@mjacobus I’m using Lotus since yesterday and I had the same behaviour trying to do some ‘tests’ with puma and siege and there is some gotchas:

  • there is the option --no-code-reloading to have a faster development, but is a tradeoff.
  • the lotus server command start WEBrick by default, using puma gem I have the server listening only on ipv6.
  • According the man pages from the siege version the URL format must be [protocol://] host.domain.xxx [:port] [/path/file]. I’m not sure if accepts the ipv6 host format [::1].
  • To bind to an ipv4 socket I used the --host 127.0.0.1 option of the lotus server command.

Best


#3

Hey man, thanks! You did some deep digging there =)

So I tried testing with --no-code-reloading and it was much faster =)

However I think that should still be faster in production mode. Development env has always some weirdness going on.